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System settings and requirements 

Minimum system requirements 

Platform 
Hardware Software 

CPU RAM Hard 
drive OS Internet 

Browser 
Windows® Intel Core 2 Duo 2.33GHz 3 GB 80 GB XP SP3 (32bit) IE 6 

Macintosh® Intel Core i7 2GHz 4 GB 500 GB Mountain Lion Safari 
 
Note: Vector NTI® Express and Express Designer are only supported on single processor machines. The 

software is not designed to run on multi-processor machines; such configurations cannot be 
guaranteed to operate successfully. 

Windows® operating systems only: Local administrator account  
On the Windows® operating system, you must be logged in as a local administrator to install the 
software. 

Dynamic licensing 
This document does not address Dynamic Licensing of Vector NTI® Express, Express Designer or DLS 
installation. Customers with a DLS License should first install and license the DLS software before 
installing Vector NTI® Express or Express Designer. 

For information on DLS installation and dynamic licensing of the software, see the DLS Installation and 
Licensing Guide, available by following the link to the software on thermofisher.com/vectornti. 

Download the software 
1. To download the software, go to thermofisher.com/vectornti and follow the links to the Vector NTI® 

Express or Express Designer download pages. 

2. Follow the instructions on the page to download the software. 

3. When the download is complete, depending on your browser settings, you are prompted to save or 
run the installer.  

Install the software 
1. If you are not prompted to automatically run the installer after download, navigate to the download 

location and double-click the installer (e.g., Vector_NTI_Express_Designer_Install_Win.exe or 
VectorNTIExpressInstall.exe) to begin installation.   

2. If a previous version of the software is installed, you are prompted to uninstall it before proceeding. 

Note: During uninstall, you are prompted to save your old database. After uninstall is complete, 
double-click the installer again to begin the installation. 

Note: We recommend installing the software on a computer hard drive, not a network drive. 

During installation, a local database is created. This database initially contains a set of standard 
vectors and other molecules from Thermo Fisher Scientific. 

http://thermofisher.com/vectornti
http://thermofisher.com/vectornti
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3. (Optional) If you are upgrading from Express to Express Designer, import your data from within Vector 
NTI® Express Designer by selecting File > Import. 

Launch the software 
Windows® operating systems: A desktop icon and Start menu folder (named Life Technologies) are 
created during installation. Double-click the icon or select the application from the Start menu to launch 
the software. 

Mac® OS: To launch the desired software, go to /Applications/VectorNTIExpressDesigner.app or 
/Applications/VectorNTIExpress.app. 

License the software 
New installations will open in Demo Mode, which allows you to perform limited operations with the 
software. You cannot save changes or analysis results in Demo Mode. Any license, whether trial, static, or 
dynamic will unlock the software from the Demo Mode. 

Order a license 
Order a license for Vector NTI® Express or Express Designer on our website at 
thermofisher.com/vectornti. Follow the links to the software pricing pages.  

For a free trial license, click the link on the desired software page, or email your contact information to 
bioinfotrial@lifetech.com.  

Types of licenses 
To satisfy the needs of users in different industrial, scientific or educational environments, Thermo Fisher 
Scientific has designed the following software licenses:  

• Trial License: Allotted to a potential purchaser of the software for a specified number of days, during 
which the user can review and use the software within certain limits.  

• Static License: Purchased by one user for installation on one computer.  

• Corporate Static License: Static license that is used throughout a corporate organization.  

• Term License: Static Licenses are also available as 1-year and 3-year fixed-term licenses. 

• Dynamic License (DLS): A license that is installed on a server and issued by that server to client 
computers running the software. DLS licenses are shared by a specified number of users or “seats,” 
with the number of users at any one time being limited to the number of “licenses” specified in the 
contract.  

http://www.lifetechnologies.com/vectornti
mailto:bioinfotrial@lifetech.com
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Enter the license number 
To license the software, you need a new License Number. If you have no connection to the internet, you 
also need a new Registration Key. The Registration Key is provided by Thermo Fisher Scientific based on 
your License number and Hardware ID. 
Enter the license into the software using the License Manager. 
 
1. Navigate to Help > License Manager. 

 

2. In the User Information tab of the License Manager, enter your information. 

 

3. Select the Applications tab. If you have a license, it displays along with the contract number. 

 

 

 

 

 

 

 

 

 

  
  
 

4. Click the type of license you have, or Trial if you do not have one. Enter the license information as 
described in the following sections.  

Note: After you enter the new license, you will need to close and restart the software to apply the 
new license to it. 
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Enter a Static License  
1. In the Applications tab, click Static. 

2. Enter your information in the appropriate fields. 

3. In the License # field, enter the software static license number provided in the email you received 
from Thermo Fisher Scientific. The hardware ID is pre-loaded in its text box. 

• Personal Static License: You must have an internet connection for this type of static 
license. Click Apply. The license is submitted via the internet and a registration key is 
returned and applied automatically. 

• Corporate Static License: You must have an internet connection for this type of static 
license. Click Apply. The license is submitted via the internet and a registration key is 
returned and applied automatically. 

 

 

If registration of your personal static license fails because of a problem with the 
internet connection, contact Thermo Fisher Scientific Technical Support and provide 
them with your computer’s hardware ID and your license number. Once you receive 
the registration key, enter the key in the Key text box of the Static License dialog box 
and click Apply. If the Key matches your license number and computer hardware ID, 
the license is registered. 

 

Enter a Trial License 
1. In the Applications tab, click Trial. 

2. Enter the trial license you received in the field, then click Apply. 

Enter a Dynamic License from a DLS Server 
To configure a Dynamic License for the software, see the Installation and Licensing Guide for Vector 
DLS 3.0 available at thermofisher.com/vectornti. 

1. In the Applications tab, click Dynamic. 

2. Enter your information in the appropriate fields. 

3. Select the DLS server requires authentication checkbox, and enter your name and password for the 
server. 

4. If you have trouble connecting to the server, click Internet Connection Settings to try new 
connection settings, then click Test Connection to test the settings. 

http://www.lifetechnologies/vectornti
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Software Updates 

Automatically or manually update software 
Each software has a software update server that can be checked automatically or manually: 

1. Go to Tools > Preferences. 

2. In the Preferences dialog, the update site URL is specified as follows: 

• For Express Designer updates: 

- For Windows®: 
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Des
igner.Updates.win32/1.0 

- For Macintosh®: 
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Des
igner.Updates.mac/1.0   

• For Express updates: 

- For Windows®: 
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Up
dates.win32/1.0 

- For Macintosh®: 
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Up
dates.mac/1.0 

3. To automatically check for updates each time the software is launched, select Automatically find 
new updates and notify me. To manually check for updates, go to Help > Check for Update after 
you have launched the software. 

Install a previous version of the software 
To go back to an older version of the software, you must first uninstall the newer version and then re-
install the older version. 

Windows® operating systems: Multiple users on the same 
computer 
The software can run from different user accounts on the same computer. (See your Windows® operating 
system documentation for information about setting up multiple user accounts.) 

Note the following: 
• With this type of installation, a single local database is shared among users on the same 

computer.  

• A local Windows® Administrator account is required to install the software, but more restricted 
accounts (e.g., Restricted User, Standard User) can run the software. 

1. From an Administrator account, install the software on the computer. 

 

Make sure that the local database is installed in an unrestricted root directory (e.g., 
the default C:\vectorntiexpressdesigner_database or C:\vectorntiexpress_database 
directory) that can be accessed by all users. 

 

http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Designer.Updates.win32/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Designer.Updates.win32/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Designer.Updates.mac/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Designer.Updates.mac/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Updates.win32/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Updates.win32/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Updates.mac/1.0
http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/UpdateSitePlugin/Updates.mac/1.0
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2. After installation, launch the software in the Administrator account, open License Manager (Help > 
License Manager), and enter the license as described in the licensing section of this installation guide 
(see page 5). 

3. Log in to each Windows® user account and run the software as usual. 

Transfer software to a new computer or operating system 
The license number and Hardware ID of your computer are closely linked. Changes to the computer 
operating system can result in a change to the Hardware ID, which will revoke the existing license. 

If the operating system changes or the software is to be moved to a different computer, you must 
unregister the license before the software is uninstalled from the current computer. An internet 
connection is required.  

1. Type unregister in License# field.  

2. Click Apply. 

3. On the destination computer, install the software, and apply the existing license. 

Using shared databases 
Databases are repositories of DNA, RNA, protein molecules, enzymes, oligonucleotides, and gel markers 
that can be shared between Vector NTI users on a network. Shared databases are not a replacement for 
local databases. The local database is used for construction, design, creation of viewers, and for storing 
private and temporary data. The purpose of the shared database is to store common data. 
 
The only operations you can perform on shared databases are: 
1. Copying data to or from the local database. 
2. Database management operations such as creating and deleting subsets. 
3. Database searches.  
 
In addition to biological data, each database contains information about its creator and registered users. 
Only the creator and registered users can have access to database data. The database creator can also 
change database properties, remove registered users, and define the password required to become a 
register user. 
 

Note: Vector NTI shared databases does not support Macintosh users. 

Shared databases can be located on a wide range of file servers—Vector NTI can work using not only 
services native to each system, (Microsoft Network or AppleTalk) but also various Unix (NFS or Samba) 
and NetWare services. 

Install the shared database 
Install the database on machine within a network that client machines can access. One client machine can 
connect to more than one shared database. When a client machine is configured to connect to multiple 
databases, it can connect a particular shared database by entering the appropriate Host Name, User 
Name, and Password.  
 
1. Click here to download the shared database executable installation file.   

2. Double-click Shared_Database_Admin_Install.exe to begin installation.  
 
The InstallShield Wizard launches. 

http://downloads.thermofisher.com/Analysis_Software/MCB/VNTI/VectorNTIExpress_v1.4.0/Shared_Database_Admin_Install.exe
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3. In the instance of a Security Warning, click Run to continue. 
 

 

4. Clicked Next to continue. 
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5. When the Choose Destination Location window displays, browse to and select the location you want 
to install the shared database, then click Next. 

 
 
The following command prompt launches to indicate that the shared database is ready to accept a 
connection. The IP address used to connect is displayed. DO NOT close this command prompt. 
Closing the window disconnects the shared database. 
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6. When prompted, click Finish. 
 

 

Shared Database Administration 
1. Launch Shared Database Admin through the Start menu as shown below. 
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The Login dialog box opens. 

2. Enter the IP address of the shared database (indicated in step 4).  Enter admin as both the username 
and password, then click Login.  
 

 
 
The User Management dialog box opens. 



 

14 Vector NTI® Express and Express Designer Installation and Licensing Guide 

3. Click Add to add a user. 
 

 

4. Enter a Name and Password, then click OK. 
 

 
 
The new user appears in the User Management table.  

Connect to a shared database from client software 
1. In Vector NTI Express or Express Designer, Select Tools> Connect to workgroup shared database…. 

2. Enter the Host Name (IP Address displayed in the command prompt), User Name, and Password, 
then click Connect.  The fields are automatically populated with the last Host Name, User Name and 
Password entered. 
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A dialog displays to indicate a connection has been established with the shared database. 
You can only connect to one shared database at a time. The connection is lost when you close Express 
or Express Designer.  

3. Click OK to continue.  
 

Upload data to the Shared Database 
Note: The workgroup shared database panel (below) does not display unless you have established 

a connection. 

1. From the Local Database in the Database panel on the left, select a data type.  
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2. Select one or more record(s) in the table, right-click, then select Upload to workgroup shared 
database. This option only appears if you are connected to shared database. 
 

 
 
A confirmation displays the number of records uploaded.  

3. Click OK to continue. 

4. Select the corresponding Workgroup Shared Database folder to view the uploaded record. 
 

 



 

Vector NTI® Express and Express Designer Installation and Licensing Guide  17 

Download data from the Shared Database 
Once in a shared database, you may download data and save it to your local database.  
 
1. Select the folder within the Workgroup Shared Database that contains your data of interest. 
2. Select the data, and right-click on it. 
3. Select Download and save to local database. 

 

 

Shared database connection troubleshooting 

Disconnection from the shared database 
If the shared database server command prompt is closed, the software will indicate that there is no 
connection to the workgroup shared database. Reconnect to the shared database. 
 
1. From the Start menu of your computer, navigate to Life Technologies > SharedDatabaseAdmin > 

Start Shared Database Server, and launch Start Shared Database Server. 
Note: If you still cannot establish a connection, continue with steps 2 and 3. 

 
2. From the Start menu on your computer, navigate to and right-click on Command Prompt, then select 

Run as administrator.  
The pathway is All Programs > Accessories > Command Prompt.  
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3. Enter ping <Shared DB IP address>, inserting your actual IP address.   
See Install a shared database server for instructions to find your IP address. 
A properly functioning network will return a reply from the server as shown below. 
If you encounter a request timeout, check if the shared database server started and is running 
properly. If the problem persists, see Firewall preventing connection. 
 

   
 

Unable to log in to the shared database 
If you cannot log in to the shared database, check that the user account was registered properly.  
 
1. From the Start menu on your computer, navigate to All Programs > Life Technologies > 

SharedDatabaseAdmin > Shared Database Admin. Launch the Shared Database Admin. 
2. Confirm that appropriate user accounts are registered in the User Management list.  

 

 
 
If the user account you are using is missing, Add it and retry logging in through Vector NTI Express 
or Express Designer client software. 

Firewall preventing connection  
Check if a firewall is turned on the computer running either the client software or the shared database 
server. Turn off the firewalls and reattempt to log in and connect. If you determine that the firewall was 
preventing connection, request your local IT administrator to enable access to the shared database server. 
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Appendix A. Technical support 

Technical resources on the web 
Technical resources for the software are available online at: thermofisher.com/vectornti.  

Annual support contract 
For personalized technical support by telephone or email, you must have a paid annual software 
maintenance and support contract. To purchase an annual support contract, email 
bioinfosales@lifetech.com or contact Thermo Fisher Scientific customer support at 
thermofisher.com/support.  

If you have a paid annual support contract, contact us by email or phone: 

• Email: bioinfosupport@lifetech.com  

• Phone: 

- 800 955 6288 x68990 (North America) 

- +44 (0) 141 814 6318 (Europe, Middle East, Africa) 

Other Thermo Fisher Scientific technical support 
For additional Thermo Fisher Scientific technical support, visit thermofisher.com/support. 

Product warranty 
Thermo Fisher Scientific Corporation and/or its affiliate(s) warrant their products as set forth in the 
Thermo Fisher Scientific’s General Terms and Conditions of Sale found on Thermo Fisher Scientific’s 
website at thermofisher.com/termsandconditions.  If you have any questions, please contact Thermo 
Fisher Scientific at thermofisher.com/support.  

 

http://thermofisher.com/vectornti
mailto:bioinfosales@lifetech.com
http://www.thermofisher.com/support
mailto:bioinfosupport@lifetech.com
http://www.thermofisher.com/support
http://www.thermofisher.com/termsandconditions
http://www.thermofisher.com/support
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Appendix B. Reinstallation policy 
 

Effective January 1, 2012, depending on the status of the Advanced Support Contract you may or may not 
have with us, the service coverage is different: 

1. If you do have a current, paid Advanced Support Contract with Thermo Fisher Scientific, then you are 
entitled to an unlimited number of license support incidents for your Vector NTI® Express or Express 
Designer software license.  However, if you do not have a current, paid Advanced Support Contract 
with Thermo Fisher Scientific, then you are only entitled to one courtesy (no charge) license support 
incident for your software license. 

2. For Vector NTI® Express Designer and Vector NTI® Express, if you do not have a current, paid 
Advanced Support Contract, Thermo Fisher Scientific grants a one-time only license support incident 
for the number of computers registered per your original purchase order. For example, if you 
purchased license(s) for 10 computers, you are entitled to a one-time courtesy (no charge) 
reinstallation for up to 10 computers. After that, no more courtesy (no charge) reinstallations are 
granted. 

3. As we introduce new major version releases, only the most current and one prior version is eligible 
for license support, regardless of the type of licensing (i.e., Static, Dynamic, Network). This is a 
standard industry practice. 

To request Reinstallation Service, please visit our website and submit out a Reinstallation Request Form, 
available on the web at: 

https://www.thermofisher.com/site/us/en/home/Products-and-Services/Applications/Cloning/vector-
nti-software/vector-nti-advance-software/Support/Re-Install-Request-Form.html 

A valid license number and hardware ID is required. 

 

 

https://www.thermofisher.com/site/us/en/home/Products-and-Services/Applications/Cloning/vector-nti-software/vector-nti-advance-software/Support/Re-Install-Request-Form.html
https://www.thermofisher.com/site/us/en/home/Products-and-Services/Applications/Cloning/vector-nti-software/vector-nti-advance-software/Support/Re-Install-Request-Form.html


For support visit thermofisher.com/support or email techsupport@lifetech.com

thermofisher.com

11 January 2016

http://thermofisher.com/support
mailto:techsupport@lifetech.com
http://thermofisher.com
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